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What’s New in iGrafx® FlowCharter™ 2007  
    
Value Stream Mapping 
 
Extended Value Stream Maps 
(EVSM) 

Benefit 

Additions to support EVSM diagrams: 
 
• New EVSM template 
• Four new sample files 
• Better curved lines 
• Four new line styles 
• New data sets (details below) 
• Improved roll-up (details below) 
 

Value stream maps describe facility-level processes.  
 
Extended value stream maps broaden the diagram 
scope to span multiple facilities across the whole 
organization.  
 
Use EVSM to uncover waste in processes that cross 
divisional and company boundaries. 

 
To create a new Extended Value Stream Map: 
On the File menu, choose New, and then choose Lean Extended Value Stream Map. 
 
EVSM samples files are available in this folder: 
C:\Program Files\iGrafx\Pro\12.0\Sample\English\VSM. 
 
A portion of the EVSMCurrentState.igx sample file: 
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Improved VSM Roll-Up Benefit 
• Easier set-up  
• Roll-up is automatic on data box and 

timeline 

Roll-up is required on EVSM diagrams, which are 
linked to one or more lower-level VSM diagrams.  
 
A manual operation is no longer required to perform 
the calculation roll-up. 
 

    
Double-click a shape on a VSM or EVSM diagram, click the Lean Data page in the Properties dialog box, 
and choose Rollup Data from the Lean Data drop-down list. Click the New button, enter a Component name, 
and click OK. By default, the following data types are rolled up: 
 

 Total processing time (Lead time) 
 Value add time 
 Raw material time 
 Work in process time 
 Finished goods time 

 
To roll up additional data such as Operators, click the Setup button, click the Add button, choose Operators 
from the New Data Type drop-down list, click Summary Box, click Add, and click OK. Click OK again to 
close the Properties dialog box. 
 
Double-click the shape to open the child diagram. Double-click the first process shape and enter “2” in the 

Operators field. Click OK and click the Back button on the Standard toolbar  to view the parent shape 
displaying rolled up values. 
 
The number of operators in the child diagram rolled-up to a parent diagram shape: 
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VSM Data Sets Benefit 
Only relevant data fields are shown for 
editing on these shape types: 
 
• Activity 
• Inventory 
• Factory 
• Transport  

 

Property dialog boxes for VSM and EVSM shapes 
are clearer to read and easier to edit.  
 
Design custom VSM templates with only the data 
fields that are pertinent to your organization. 

 
To change the shape data set: 
Double-click a new process shape on a VSM or EVSM diagram, expand the Activity drop-down list (to the 
right of the Lean Data drop-down list) and choose a data set. By default, these sets are available: 
 

 Activity 
 Inventory 
 Facility 
 Transport 

 
To create a new data set, in the Properties dialog box, click the Setup button, click the Data Sets button, 
and then click the New button. Type the data set name and then select custom data fields to include in the 
data set.  
 
Choosing custom data fields for the Activity data set:  
 

 
 
 
When you are done selecting data fields, click OK, click OK again to save your Setup. Your new data set is 
now in the list of data sets. Click OK to save and close the Properties dialog box.
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Enhanced Timeline Benefit 
Display these calculations on the 
Timeline and/or the Timeline summary 
box: 
 
• Total processing time 
• Value add time 
• Raw material time 
• Work in process time 
• Finished good time 
• Rolled throughput yield 
• In-plant time 
• Transport time 
• Process cycle efficiency 
• User-defined data on timeline 

 

Experiment on activity changes or inventory 
adjustments and automatically see the impact on 
common Lean measurements.  
  
Present value stream information in formats 
managers can use to take action. 

 
To add raw material time to the VSM current state sample file timeline:  
Open C:\Program Files\iGrafx\Pro\12.0\Sample\English\VSM\VSMCurrentState.igx. Double-click the timeline 
and click the Add button. In the Timeline Data dialog box, set New Data Type to Raw Material Time, select 
On Timeline, and type “RM” in the adjacent field. Click the down arrow in the Display Format section and 
set units to days. Close the Display Format drop-down (by clicking the X), click the Add button and click OK. 
 
Raw material time shown with the 
timeline: 

Raw material time shown in the 
summary box: 
 

 

 

 
 
Value Added Time Benefit 
Enter value added time (new) or let 
iGrafx calculate value added time for you 
(as in previous versions). 
 

Choose a preferred method of specifying value 
added time. 

 
To use: 
Create a new VSM diagram (from the File menu, choose New and then Lean Value Stream Map), double-
click the first process shape, click the Lean Data page, and enter a number for the Value Add field. Click in 
another data field, and notice that Total C/T (Processing Time) is automatically calculated. Click OK, and 
your Value Add time is shown in the data box and timeline, as it was in previous versions. 
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 Improved Distance Line Benefit 
The distance line is enhanced from a 
single calculation method to show 
distances between: 
 

VSM EVSM 
 Activities 
 Inventories 
 Both 

 Facilities 
 Transports 
 Both 

 
 

Understand how facility layout and distances 
between process steps impact the value stream. 

 
To display distances traveled within and between activities: 
Open the VSMCurrentState.igx sample file. Double click the left-most inventory shape, Coils, and enter “20” 
in the Distance Traveled field and “ft” in the Distance Traveled units drop-down. Click on each of the 
following shapes and set these distances, and then click OK: 
 

Shape Distance 
STAMPING 5 feet 
The inventory shape after Stamping 50 feet 
S. WELD #1 10 feet 
 
Double-click the timeline, choose Timeline in the Source drop-down list (to the right of the Show Distance 
Line check box), choose Feet in the Display Format drop-down, and click OK. 
 
A portion of the VSM distance line displaying distances within and between activities: 
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Data Descriptions and 
Formulas 

Benefit 

Click the data name to view its: 
 
• Description (if written by the user) 
• Formula (if a calculated field)   
 

Describe how value steam fields are used and 
interpreted. 
 
See how calculated data is evaluated.  
  

 
To view formulas: 
Double-click a shape in the VSMCurrentState.igx sample file, click the Lean Data page in the Properties 
dialog box, click the Setup button, and click the New button. Rename “Custom Data1” to “Capacity”, set Lean 
Types to Capacity (Calc.), and click OK. In the Properties dialog, find the “Capacity” field (you may have to 
scroll down) and click on the word “Capacity”. 
 
The Properties dialog box displaying the Capacity lean data formula: 
 

   
 
 
To view descriptions: 
Double-click an inventory shape in the VSMCurrentState.igx sample file, click the Lean Data page in the 
Properties dialog box and click the Setup button. Click the “L” Custom Data field and type “Left hand drives” 
in the Description box. Click OK and in the Properties dialog, click on the letter “L”.  
  
The Properties dialog box displaying the lean data description for the “L” lean data: 
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FMEA Sheets  
 
Use FMEA (Failure Modes and Effects Analysis) sheets to analyze potential reliability problems and their 
causes. The FMEA prioritizes potential failures according to their risk and drives actions to eliminate or 
reduce their likelihood. FMEA sheets in iGrafx can be linked to Cause and Effect diagrams, can automatically 
calculate AIAG Occurrence rankings, and are part of the iGrafx file for ease of distribution. 
 
 
Part of the iGrafx Document Benefit 
Create, edit, view and print a FMEA 
spreadsheet from within iGrafx. 
 

FMEA spreadsheet is bundled with your Cause and 
Effect (C&E) diagram so FMEA data isn’t lost when 
iGrafx files are distributed.  
 

 
To create an FMEA spreadsheet: 
On the File menu, point to New and choose Cause and Effect Diagram. On the Cause and Effect menu, 
choose Export To FMEA Sheet. In the Generate FMEA dialog box, click OK, type the name of the FMEA 
component you are creating, and click OK. 
 
An FMEA spreadsheet generated from a new Cause and Effect diagram:  
 

 
 
 
Bidirectional Link to C&E Benefit 
Change the content of either the FMEA 
or C&E and the linked object is 
automatically updated. 
 

The bidirectional link guarantees that the FMEA is 
always synchronized with the C&E text and data. 

 
To try this feature: 
Follow the steps above to create an FMEA spreadsheet. In the spreadsheet Potential Causes column, 
double-click the text “Sub cause 1”, highlight (select) the text, and change the text to “No training”. Click the 
link arrow at the far left of the row. 
 
Notice that the cause text in the diagram and the Cause and Effect Explorer are both automatically updated 
when the FMEA is changed.  



March, 2007 

What’s New in iGrafx® 2007  iGrafx® Division of Corel®, Inc. 
  Page 10 of 41 

 
AIAG Occurrence Ranking Benefit 
iGrafx FMEA worksheets calculate and 
display Automotive Industry Action 
Group (AIAG) occurrence rankings or 
cause error numbers.   
 

Automatically convert failure rates to the AIAG 
ranking scale from 1 to 10. 
   

 
To change AIAG occurrence rankings: 
Create a new Cause and Effect diagram (On the File menu, point to New and choose Cause and Effect 
Diagram). In the Explorer bar set the Sample to “20” and # Errors for “Sub cause 1” to “1” as shown: 
 

 
 
Create an FMEA sheet (On the Cause and Effect menu, choose Export To FMEA Sheet, click OK, click OK 
again). View the Occurrence column. The occurrence ranking for “Sub cause 1” is “7” because the failure 
rate is 1 in 20 and the ranking for the other causes are “10” because the failure rate is at least 1 in 2.   
 
This table of AIAG rankings is available in the iGrafx Help:  
 
Probability of Failure Possible Failure 

Rates 
Rankin
g 

Very High: Failure is almost inevitable 1 in 2 10 
 1 in 3 9 
High: Repeated failures 1 in 8 8 
 1 in 20 7 
Moderate: Occasional failures 1 in 80 6 
 1 in 400 5 
 1 in 2,000 4 
Low: Relatively few failures 1 in 15,000 3 
 1 in 150,000 2 
Remote: Failure is unlikely 1 in 1,500,000 1 
   
 
 
To use errors entered in the Cause and Effect directly, instead of AIAG rankings: 
In the FMEA sheet, right-click the top cell of the Occurrence column (circled below) and choose Column 
Properties. 
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The Column Properties dialog: 
 

 
 
Choose Cause and Effect Pareto Value in the Other drop-down. Click OK, and the Occurrence rankings will 
now use the numbers entered in the Cause and Effect diagram’s # Errors column. 
 
 
Hierarchical Cause Numbering Benefit 
When creating a FMEA from a C&E, 
causes are automatically numbered 
hierarchically based on their position. 
 

The FMEA shows the relationship between causes. 

 
To enable or disable cause numbering: 
With a new or existing Cause and Effect diagram, on the Cause and Effect menu, choose Export To FMEA 
Sheet. In the Generate FMEA dialog box, click Include Section Number to turn on or off the cause 
numbering in the FMEA sheet. 
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Prioritization Matrix 
 
The prioritization matrix helps Six Sigma and process improvement teams make decisions by ranking options 
and issues based on specific criteria. 
 
Part of the iGrafx Document Benefit 
Use a pre-defined template to design the 
Prioritization Matrix within iGrafx. 
 

iGrafx reduces the time it takes to build and modify a 
Prioritization Matrix. 
 
The Prioritization Matrix is bundled with your C&E 
diagram so data can’t be lost when iGrafx files are 
distributed.  

 
To create a prioritization matrix: 
Create a process map (from the File menu, choose New and then Process) with three shapes labeled 
“Activity1”, “Activity2”, and “Activity3”. Double-click ”Activity1”, click the Custom Data page in the Properties 
dialog box. In the Setup Custom Data dialog box, click the Setup button, click the New button, type 
“Availability”, and then create two additional fields called “Impact” and “Likelihood”. Click OK. 
 
In the Properties dialog box, Custom Data page, enter ”3” for Availability, ”4” for Impact, and ”5” for 
Likelihood. Click on the ”Activity2” shape, and enter ”2” for Availability, ”5” for Impact and ”3” for 
Likelihood. Click on the ”Activity3” shape, and enter ”5” for Availability, ”2” for Impact and ”4” for 
Likelihood. Click OK. 
 
On the File menu, choose Components. Right-click inside the Documents Components Explorer and choose 
New, choose Prioritization Matrix, and then click OK. 
 
Right-click the left-most cell in the first row labeled “Step” and choose Row Properties. Choose Shape or 
Graphic, click the ellipses button , click on Process1, click on Activity1, click OK, and then click OK 
again. Repeat this procedure to link the next two rows to Activity2 and Activity3. 
 
Right-click the top cell of the first column labeled Output (circled below) and choose Column Properties.  
 

 
 
In the Column Properties dialog box, choose Custom Data, set the drop-down to Availability, and then 
click OK. Repeat this procedure to link the other Output columns to Impact and Likelihood. Adjust the 
column widths if necessary. Your prioritization matrix should now look like this: 
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Bidirectional Linkage Benefit 
Link process activities and their custom 
data to matrix cells. Changes to either 
component automatically update the 
linked component.  
 

Manage and analyze data stored on multiple 
processes and activities from a single spreadsheet.  
 
 

 
To try this feature: 
In the Prioritization Matrix created above, double-click the label “Activity1” and rename the cell to “Check 
Order”. Click the arrow on the far left of this row  to view the diagram. The label of the shape is renamed.  
 

Rename the shape “Update Order” and then click the Back button . The label in the matrix is updated. 
 
In addition, if matrix values or diagram custom data field values are changed, their corresponding values in 
the linked matrix or diagram are automatically updated.  
 
Weighted Calculations Benefit 
The prioritization uses criteria values and 
their weighting.  
 

The Prioritization Matrix lists options as rows and 
selection criteria as columns. Multiplying criteria 
weights by entered values gives the priority ranking.  
 

 
To change priority weights: 
In the Prioritization Matrix created above, change the values of cells in the row labeled “Weight”. Modifying 
these cells will change the totals in the last column. 
 
Automatic Highlighting Benefit 
Matrix cells containing criteria values 
automatically display color highlights 
such as red, yellow, green, depending on 
the value contained. 
 

Use color to highlight the high priority ideas for 
improving your processes. 
 
 

 
To highlight priorities: 
In the Prioritization Matrix created above, select the nine cells with values under the “Correlation” heading. 
Right-click and choose Format Cells. In the Cell Formatting dialog box, click the Cell tab, select Conditional 
Cell Formatting, then click the Ranges button. In the first row enter the range “0” to “2”. In the second row 
enter the range “3” to “4”, and in the third row enter the range “5” to “10”, click OK, and click OK again. 
 
Your prioritization matrix may now look like this: 
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Basic Sheets  
 
Basic Sheets Benefit 
Create sheets (grids) of data that are 
linked to process models.  
 
 

These sheets work like FMEA and Prioritization 
Matrix sheets, but are used for general purpose and 
ad hoc analysis. 
 

 
To create a basic sheet: 
On the File menu, choose Components. Right-click inside the Documents Components Explorer, point to 
New and choose Basic Sheet. Type a name for your new component, and then click OK. You may now link 
rows and columns to diagrams, similar to how you created links for the Prioritization Matrix described above. 
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Cause and Effect (C&E) Diagrams 
 
Error Roll-up Benefit 
Error rates for sub-causes are 
automatically summed to parent causes. 
 
View and hide sub-causes in the 
Explorer bar C&E window to 
automatically change the Pareto Chart 
data points. 
  

iGrafx integrates three views of C&E data into a 
single document. Changes in one view are 
immediately reflected in other views.   
 
Choose the best method to communicate and 
analyze C&E relationships. 
 

 
On the File menu, choose Open and navigate to C:\Program Files\iGrafx\Pro\12.0\Sample\English and open  
Cause&Effect.igx.  
 
In the Explorer bar, errors entered for sub-causes (e.g. Molding) are rolled up to their parent branch (e.g. 
Machines): 
 

 
 
On the File menu, choose Save As and save a copy of the file to a folder on your computer.  
 
Scroll the diagram down so that the Pareto Chart is visible and then click the collapse button  next to 
“Machines” and the other major branches until the Explorer bar looks like the picture below.  
 
Notice that the Pareto chart is updated to display only the major branches: 
 

 
 
To show a Pareto chart in a new Cause and Effect diagram, on the Cause and Effect menu, choose Insert 
Pareto Chart.  
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Auto Layout Enhanced Benefit 
Several new controls improve the auto 
layout feature: 
 
• Branch sizing 
• Main and sub-branch alignment 
• Sub-branch positioning 
• Text alignment 
 

Spend less time drawing and let iGrafx layout the 
diagram. 
 

 
With a new or existing cause and effect diagram, on the Cause and Effect menu choose Layout Diagram. 
  
This a portion of a Cause and Effect diagram before using the auto layout: 
 

 
 
After using the above and below switch in the Layout Diagram dialog box: 
 

 
 
The Cause and Effect diagram becomes easier to read: 
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Sample Size Benefit 
Enter the sample size in the C&E window 
of the Explorer bar.   
 
The sample size and error rates are used 
to automatically calculate AIAG 
occurrence rankings in FMEA diagrams. 
 

The sample size provides the context for the error 
values associated with causes.  
 
 

 
See the AIAG Occurrence Ranking feature description in this document for an example modification of the 
sample size. 
 
New Templates Benefit 
Three C&E diagram templates are now 
available instead of one. 
 

Get a fast start on new diagrams. 

 
On the File menu, choose New and then choose any of these templates: 
 
 Cause and Effect Diagram  
 Cause and Effect (Manufacturing) 
 Cause and Effect (Transactional) 

 
More Improvements 
 
Publish PDF  Benefit 
Export iGrafx files to Adobe Acrobat files 
with these features: 
 
• Links between diagrams 
• Links to specific pages of Microsoft® 

Office and Adobe® Acrobat® 
documents 

• Links between paginated pages 
• Watermarks 
 

PDF is the standard electronic document interchange 
format.  
 
Communicate and collaborate more easily with 
colleagues who don’t have access to iGrafx software. 
  

 
To publish PDF: 
On the File menu, choose Publish As and then choose PDF Document. 
 
The Publish As PDF Document menu: 
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Page Setup Flexibility Benefit 
Define the page setup for all components 
from a single dialog. Settings include 
header and footer, margins, scaling, 
orientation, watermarks, and more. 
 
Use global settings when appropriate. 
 
Copy and paste page settings between 
components. 
 

Combine landscape and portrait diagrams in a single 
document.  
 
Apply print settings with speed and control. 

 
To apply the same page format to all file components: 
Open the document C:\Program Files\iGrafx\Pro\12.0\Sample\BPMN.igx. On the File menu, choose Page 
Setup. In the left frame, right-click Main Voting Process and choose Copy page setup to clipboard, right-
click BPMN.igx (at the top of the left frame) and choose Apply page setup from clipboard.  
 
In the left frame, click Collect Votes and then select Use document settings on the Page tab. Repeat this 
step for each component. The Page Setup dialog: 
 

 
 
For new documents, Use document settings is enabled for all document components. 
 
Watermarks Benefit 
Digital watermarks are visible text that 
displays and prints in the background 
over a document.  
 
Vary the font, rotation, spacing and 
intensity of watermarks. 

Ensure that draft and unapproved documents are 
clearly marked.  
 
Place copyright and other notices prominently.  

 
To use with any document: 
On the File menu, choose Page Setup. In the left frame, click a diagram name and then click the Watermark 
tab. Select the Enable watermark check box and type “Draft” in the text field. Click OK and then view the 
component you applied the watermark to. A BPMN diagram with a watermark: 
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Link to Shapes Benefit 
Define links from shape to shape within a 
diagram or across diagram boundaries. 
 

Define associations between related activities.  
 
Navigate more easily within or across process map 
boundaries. 
 

 
To use: 
Create a new process diagram and add a shape labeled “Finish”. Select the “Start” shape and on the Insert 
menu choose Link. Change the Diagram Name to “Process1”, select the Link to Shape check box, click , 
choose “Finish” in the Pick Diagram Object dialog, and click OK. 
 
To test the link, right-click the “Start” shape and choose the shape name at the bottom of the menu. 
 
The Add Link dialog: 
 

 
  
 
Bookmark Links Benefit 
Link iGrafx shapes to bookmarks in 
Microsoft Office documents, web pages 
and Adobe Acrobat files. Link to: 
 
• Bookmark name (Word or HTML) 
• Named range (Excel®) 
• Slide number (PowerPoint®) 
• Page number (Acrobat) 
 

Use links to describe activities with supporting 
documentation. 
 
Navigate to the bookmarked text in your linked files 
instead of the first page. 

 
To create a bookmark link: 
From Microsoft Word, open a multi-page document and scroll past page 1. On the Insert menu, choose 
Bookmark. Name the bookmark “Destination” and click the Add button. Close and save the document. 
 
From iGrafx, open or create a new diagram and select a shape. On the Insert menu, choose Link. Choose 

File or Web Page and click the Folder button  . Navigate to the Word document containing the 
bookmark, select it, and click Open. In the Bookmark field, type “Destination” and click OK. 
 
To test the link: 
Right-click the linked shape and choose the Word document name at the bottom of the menu. 
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Hierarchical Shape Numbering Benefit 
In hierarchical processes, one or more 
shapes are linked to subprocesses. The 
sub-process shape numbers are updated 
if the parent shape number changes. 
 

iGrafx saves time by automatically maintaining the 
correct shape numbers in hierarchical models.  

 

 
To display hierarchical shape numbering: 
Create a new process map. Double-click the “Start” shape and choose the Process page. Change the 
Activity Type drop-down to Subprocess, click the New button and click OK twice. In the Toolbox Toolbar, 
click the Numbering tool  and choose Show All Shape Numbers. Right-click the “Start” shape and 
choose Process2. In the Toolbox Toolbar, click the Numbering tool and choose Show All Shape 
Numbers.  
 
Return to the parent diagram and modify the number of the “Start” shape by clicking the Numbering tool and 
choosing Auto Renumber. Type “2” in the Starting Number field and click OK. Right-click the “Start” shape 
and choose Process2. The subprocess shape number has been updated to “2.1”. 
 
Original parent shape: Original child diagram shape: 

  
If the parent shape is renumbered: Shapes in the child diagram are 

automatically renumbered: 

  
 
 
Enhanced Visio® Import Benefit 
New optional features for files created 
with Visio 2000, 2002, 2003 or 2007: 
  
• Convert multi-page Visio diagrams to 

a single iGrafx component 
• Improved import of grouped shapes 

as single iGrafx shapes  
• Convert headers and footers 
 

Upgrade faster from Visio to iGrafx. 
 
Convert and extend Visio files to iGrafx format for 
process analysis and simulation. 
 
 

 
To import Visio diagrams: 
On the File menu, choose Open. Navigate to a Visio diagram with any of the features described above. 
Select the Visio file and click Options. Set the desired options and click OK and then click Open. 
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Improved Java® Web 
Publishing 

Benefit 

New features include: 
 
• Initial zoom level setting 
• Link behavior control 
• Optional control over header and  

footer display and web output 
printing 

 

Customize the web view of iGrafx documents to fit 
corporate web content standards.  

 
To publish diagrams to Java format with the new link behavior: 
Open a new or existing document such as C:\Program Files\iGrafx\Pro\12.0\Sample\ACME_Order.igx. From 
any of the shapes create a link to another shape (see the Link to Shapes section above for instructions). 
Add a second link from the source shape to a third shape in the diagram. 
 
On the File menu choose Publish As and then choose Web Page. Select the Order Fulfillment process and 
set the Output Format to Java Applets. Click the Advanced button, set the options as desired and click OK 
and click OK again. 
 
When asked to see the published document, click the View button. In the Java output, click the shape with 
two links to test the behavior you specified. 
 
In this published Java output, the “Receive Order shape” is linked to two other shapes: 
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Custom and Lean Data 
Formatting 

Benefit 

Describe how lean data, custom data, 
and sheet data are displayed. Number 
formatting options include:  
 
• Set precision up to 6 places 
• Optionally include 1000s separator 
• Describe negative number format 
 

Improve the display of numeric data on Lean 
diagrams and other documents. 

 
To format custom and lean data: 
Double-click a process shape in a new value stream map. In the Properties dialog box, choose the Lean 
Data page, click the Setup button, select Total C/T. Click the Format down arrow and select Fixed Decimal 
Places check box, enter “6” to set the precision to six places, and then click OK. 
 
Note: Negative numbers are generally not used for lean data fields.  
 
The Format control: 
 

 
 
Improved Documentation Benefit 
Read the new Rapid Learning Guide, 
Simulation Quick Reference Guide and 
Process Diagrams Quick Reference 
Guide. 
 
The iGrafx 2007 Help system is 
reorganized into procedural, reference, 
and conceptual help topics. 
  

Get immediate answers to your questions with task-
based procedures and reference material focused on 
end results.  
 
Conceptual topics are separate from procedures so 
that task-based information is pulled out and 
uncluttered with background information.  
 

 
To view the Page Setup procedures: 
On the Help menu choose iGrafx Help. Select the Contents tab, expand Documents and Diagrams 
Procedures and click Page Setup. The description is written as a series of procedures.  
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New Tutorials Benefit 
Access new tutorials from the Welcome 
dialog box or Help menu: 
 
• Lean VSM 
• Process behavior modeling 
• What-If analysis and simulation 
• Six Sigma analysis 
• Cause and Effect diagrams 
• BPMN diagrams 
 

Become productive faster with tutorials that provide 
step-by-step instructions to create, analyze, and 
improve process models. 

 
To view tutorials: 
On the Help menu choose iGrafx Tutorials.  
 
Enterprise Field Codes Benefit 
Display values of activity enterprise 
properties on diagrams. The new display 
fields work on these existing values: 
 
• Measurements 
• Risks 
 
Fields that display the values of these 
objects require iGrafx® Enterprise 
Central™: 
• Goals 
• Requirements 
• Strategies 
• Business rules 
• Input and output work products 
 

Visualize and communicate enterprise data stored at 
diagram process shapes. 
 
Run custom macros to display real-time data (for 
example, the latest performance measurement) 
imported to enterprise fields. 
 
  
 

 
To create an enterprise field code: 
Open the ACME_Order.igx sample file. Double-click the “Credit OK?” Shape.  In the Properties dialog box, 
click the Enterprise page, click the Measurements tab, click the Add button, in the Name field, type “Actual 
Approved” and click OK. In the Value field, type “95” and click OK.  
 
Right-click the “Credit OK?” shape and choose Fields.  In the Shape Fields dialog box, click the New Field 
button. In the New field dialog box, expand Enterprise Data and choose Measurements Block. Set the 
Format and Filter blocks as desired and click OK. In the Location section of the Shape Fields dialog box, 
choose a location under the shape and click OK. 
 
The “Credit OK?” shape with a measurements field.  
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Collapsible Departments Benefit 
In the Swimlane® name area, hide and 
display one or more levels of 
organizational hierarchy.  
 

Simplify the diagram for better communication. 

 
To hide a department level: 
Create a new process diagram. Change the name of “Dept. 1” to “Parent department”. On the Insert menu, 
choose Department, change the Location drop-down to Child of, in the New Department Name field, type 
“Child department 1” and click the Apply button. In the New Department Name field, type “Child department 
2” and click OK. On the View menu, point to Departments and choose Hide One Department Level. 
 
Department names created from a Process Central resource model can also be hidden.  
 
Original diagram: 
 

 
 
Diagram after hiding one department level: 
 

 
 
 
New Arrowheads Benefit 
New arrowheads are available: 
 

 

Layout and electrical diagrams use these new 
arrowheads. 

 
To apply a new arrowhead: 
Right-click a diagram line and choose Format. In the Format Line dialog box, click the Arrows and 
Crossovers tab, and then choose an arrowhead from the Source Arrow or Destination Arrow drop-downs. 
Alternatively, use the Arrows tab of the Gallery displayed on the right border of the tool.  
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File Properties Benefit 
View basic properties of iGrafx files such 
as the pathname, size, and author. 
 

From within iGrafx, quickly see where a document 
resides.  

 
To set file properties: 
Open an existing diagram and on the File menu, choose Properties. 
 
Unicode Support Benefit 
Unicode is an industry standard 
designed to allow multi-lingual text and 
symbols to be consistently represented 
and manipulated electronically. Use with: 
 
• Diagram shape text 
• Header and footer text 
• Watermarks 
• Component names 
• Swimlane names 
• Modeling attributes  
 

Use multiple languages within all iGrafx text fields. 
 
Create multi-lingual process models that are shared 
internationally. 
 

 
 
Additional Enhancements Description 
Grid snapping increments 
 

Describe the grid units in millimeters or imperial units. 

Custom data “product” accumulation 
 

Create a custom data summary result by multiplying 
custom data values. 
 

Set the output path of the publish web 
project name  
 

Name the root publish folder from the dialog. 

Set the file name when publishing to 
Microsoft PowerPoint and Word 
 

In iGrafx 2006 the output file name is set by the tool. 

Automatic Custom Data roll-up to parent 
processes 

In iGrafx 2006 a command is run to roll-up Custom 
Data values from subprocesses. Roll-up is automatic 
in iGrafx 2007. 
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What’s New in iGrafx Process™ 2007 and iGrafx Process™ 2007 for Six 
Sigma 
 

Resource Model  
 
The resource model is available in FlowCharter but achieves its greatest value when used for simulation 
analysis with iGrafx Process and iGrafx Process for Six Sigma.  
 
 
Availability Benefit 
Qualify resources by both schedule and 
availability percentage.  
 
Model periodic and unscheduled 
resource downtimes. 
  

Restrict resource usage across multiple processes.  
 
For example, a resource might be available to the 
claims process 75% of the time and the payments 
process 25% of the time. 
 

 
To specify resource availability: 
Open the ACME_Order.igx sample file. On the Model menu, choose Resources. If the Show Allocations 
button is visible then click it. Click the Resource List tab and select the “Sales” resource. In the Properties 
tab, next to Availability, select the Limited check box, enter “75” and click OK. 
 
The Define Resources dialog with Availability circled: 
 

 
 
Continue using ACME_Order.igx in the following steps. 



March, 2007 

What’s New in iGrafx® 2007  iGrafx® Division of Corel®, Inc. 
  Page 27 of 41 

 
Skill Level and Attributes Benefit 
Set the skill level of any individual or 
pool.  
 
Create custom resource attributes. 
 

Acquire resources by skill level or express task 
duration times by resource skill level. 
 
Create a more authentic resource model by 
assigning resource attributes that impact process 
flows.  
 

 
To specify resource skill level: 
If not open already, open the ACME_Order.igx sample file. On the Model menu, choose Attributes. Select 
the Resource Location, click the Add button, under Attribute Name, type “Skill”, click OK, and click OK 
again. 
 
On the Model menu, choose Resources. If the Show Allocations button is visible then click it. Select the 
Resource List tab, then click the Add button and choose Resource.  Type “C & I Trainee”, select the 
Properties tab, type $10.00 for the hourly rate. Click the Attributes tab, then click the Add button and 
choose Initialization. Ensure that Location is set to Resource. Set Name to “Skill” and set Value to “1” as 
shown below. 
 

 
 
On the Resource List tab, choose the resource “C & I (2)”. On the Attributes tab, click the Add button and 
choose Initialization. Ensure that Location is set to Resource. Set Name to “Skill” and set Value to “2”. 
 
Click the Properties tab and change the Use to Individual. 
 
Leave “C & I” highlighted in the Resource List. While holding the CTRL key down, right-click “C & I Trainee”, 
choose Allocate to Organization, choose Credit & Invoicing, and click OK. Choose the Organizations tab 
and select the Credit and Invoicing organization. The Resources section shows that “C &I” and “C & I 
Trainee” are allocated to the Credit and Invoicing organization as displayed below: 
 

 
 
Click OK to close the Define Resources dialog and continue the instructions in the next section. 



March, 2007 

What’s New in iGrafx® 2007  iGrafx® Division of Corel®, Inc. 
  Page 28 of 41 

  
Resource Constraints Benefit 
Acquire resources according to user-
defined rules.  
 

Qualify how and when resources are used.  
 
For example, an activity may require a resource with 
a minimum certification level. 
 

 
To use a resource constraint, perform the steps above then continue with these steps: 
Double-click the “Check Credit” shape. In the Properties dialog box, click the Resources page. If the 
Constraint field is not displayed then click the More Resource Details button . Click the Expression 

Builder button  in the Constraint field, click the Paste Attribute Name button   select Resource in 
the Location area, choose Skill and click OK. Type “> 1” after the attribute name and click OK. The 
Constraint field now looks like this: 
   

 
 
On the Model menu, choose Run Setup, click the Initialization/Reports tab, click the Append to Report 
option, and click OK.  
 
On the Model menu, point to Run and choose Start. 
 
A simulation report is displayed. Click the Custom tab and scroll down to the graph showing Average 
Waiting Time for Transactions that Waited.  
 
Notice that there is a large increase in the waiting time in the “Credit and Invoicing” department because the 
“Check Credit” activity (which has the longest duration time in the process) must acquire a skilled worker to 
perform the activity. 
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Alternative Resources Benefit 
In the Properties dialog box – Resources 
page, specify if just one or all listed 
resources are acquired at an activity 
shape. 
 
Acquire resources from any department 
(not just the department containing the 
activity). 
  

Model activities where any of multiple resources can 
perform the task.  
 

 
To specify alternative resources: 
Open the ACME_Order.igx sample file. On the Model menu, choose Resources. If the Show Allocations 
button is visible then click it. Choose the Resource List tab, click the Add button and choose Resource 
Type, type “Partner” and click OK. 
 
Double-click the shape “Complete Order”. In the Properties dialog box, click the Resources page, click the 
Add button, change the Type of the added resource to Partner, select the Any One choice (circled in the 
picture below) and click OK. 
 
The Properties dialog (with less resource details displayed) after allowing either a Partner or Default 
resource to perform the “Complete Order” step: 
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Acquisition Groups Benefit 
Team multiple resources into a named 
group that’s acquired by multiple 
activities in the model.  
 

Commonly used sets of resources are defined once 
and then referenced where needed. Reduce 
modeling time by reusing common resource teams.   

 
To create an acquisition group: 
Perform the steps in the above feature description. On the Model menu, choose Acquisition Groups, click 
the Add button under the acquisition groups list. Click the Add button in the lower right portion of the dialog 
box (circled below): 
 

 
 
Change one of the Type drop-downs to Partner, select the Any one option, and click OK. 
 
To use an acquisition group at an activity: 
Double-click the shape “Complete Order” and select the Resources tab. If there are two resources listed, 
select one of the resources and click the Delete button.  Change the Type of the remaining resource to 
Acquisition Group, and click OK. 
 
The Properties dialog acquiring an acquisition group: 
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Improved Infrastructure 
Support 

Benefit 

Represent non-human resources more 
easily. These include printers, software, 
systems, and other infrastructure, that 
support processes and activities. 
 
Represent non-worker resources, such 
as the HR system, as swimlanes. 
 

Architect how non-human elements of your 
enterprise support and sustain your processes.  
 
 

 
To create resources and organizations: 
Open the ACME_Order.igx sample file. On the Model menu, choose Resources. If the Show Allocations 
button is visible then click it. Select the Resource List tab, click the Add button, choose Resource, and type 
“Scheduling”.  
 
Click the Add button and choose Resource type, select Other under Classification, right-click the “Type1” 
resource type, choose Rename and type “Systems”, and press the Enter key. Right-click “Systems-A”, 
choose Rename, and type “SAP”. The Define Resources dialog box after creating the “Scheduling” and 
“SAP” resources: 
 

 
 
Click the Organizations tab. Right-click Production, point to Add and choose Child, then type 
“Manufacturing”. Right-click Production, point to Add and choose Child, then type “Scheduling”.  
 
Click the Add button, choose Top-Level, type “SAP”, and press the Enter key. Right-click “SAP” and choose 
Allocate Resources. In the Choose Resource dialog box, expand “Systems”, select SAP, and click OK.  
 
The Define Resources dialog box after adding three additional organizations: 
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Click OK in the Define Resources dialog box. 
 
To add new swimlanes representing organizations defined above: 
Right-click the Name area of the “Production” swimlane and choose Insert Department.  In the New 
Department Name drop-down, choose SAP. Leave the Location drop-down set to Before and Production 
as shown below and click the Apply button. 
 

 
 
Change the Location drop-down to Child of. In the New Department Name drop-down, choose 
Scheduling, and then click the Apply button. In the New Department Name drop-down, choose 
Manufacturing and click OK.  
 
Move the “Make Product” and “Assemble Packages” shapes to the “Manufacturing” swimlane. Delete the 
connection line between “Receive Order” and “Check Credit. Add a shape labeled “Update Database” to the 
“SAP” swimlane and connect it as shown below: 
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On the Model menu, choose Resources. Notice that the icons for the “Manufacturing“, “Scheduling“, and 
“SAP“ organizations have changed to  indicating they are represented by swimlanes in the diagram:  
 

 
 
Also notice that new worker resources are automatically created and allocated to the “Manufacturing” and 
“Scheduling” organizations because the swimlanes representing them contain activities that acquire a Default 
resource.  
 
To avoid automatic worker allocations to the “SAP” organization, we allocated the “SAP” resource to the 
“SAP” organization.  
 
 
Organization Hierarchy  Benefit 
Describe organization hierarchy, roles, 
groups, pools, and individuals.  
 
Choose resource model organization 
units when adding swimlanes from the 
Department Manager. 
 

Allocate resources to their appropriate roles and 
organization units.  
 
Build a clear picture of the human resource structure 
of an enterprise. 
 
Update swimlane names in multiple processes from 
the resource model. 
 

 
To create organization hierarchy, follow the steps in the previous section. 
 
Exchange Resource Models  Benefit 
Export and import resource models using 
XML. 

Export a resource model and use it in a separate 
model created by you or others in your organization.  
 

 
In the Define Resources dialog, click the Export button, navigate to any folder on your hard drive, in the File 
Name field, type “ACME resource model”, click the Save button, and click OK. 
 
Create a new Process diagram. On the Model menu, choose Resources, click the Import button, select the 
XML file saved earlier, and click Open. The resources and organizations defined in the XML file are now 
available to the current model. 
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Other Modeling Enhancements 
 
Where Used  Benefit 
Display where and how model elements 
are used by process activities. Some of 
the searchable objects are:  
 
• Resources 
• Organizations 
• Schedules 
• Transaction attributes 
• Scenario attributes 
 

View the model objects affected by changes. 
 
Find important process data faster. 
 
Make model changes and improvements with fewer 
errors.  
 

 
To see where model objects are used: 
On the Tools menu, choose Where used. 
 

 
 
Additional Enhancements Description 
Activity attributes Use custom data fields in activity descriptions. For 

example, a custom data field can be used in an 
expression defining the activity work time.  
 

Improved expression error messages 
 

iGrafx provides a better description of the location of 
syntax errors.  
 

Dozens of new system functions, for 
example, Switch and Select. 

 

The new functions are for transaction flow control 
and manipulating string values and resources. 
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What’s New in iGrafx® Process Central® 
 
Upgrade your Process Central repositories to iGrafx 2007 format before attempting the new features 
described below. 
 
Document Cycles  Benefit 
Three document life cycle procedures 
are available:  
 
• Review (new feature) 
• Approve  
• Endorse (new feature) 

Solicit comments on draft processes with a review 
cycle before the approval procedure.  
 
Confirm receipt and understanding of an updated 
process with an endorse cycle after the approval 
procedure. 

 
To start cycles and define user lists: 
In the Process Central Explorer bar, select an object. On the ProcessCentral menu, point to Cycles and 
choose Manage.  
 
The Manage Cycles dialog box: 
  

 
 
Cycle Notifications and 
Subscriptions 

Benefit 

When repository documents change 
status, email notifications are delivered 
to users. For example, reviewers can be 
notified when a review cycle is complete. 
 
A subscription sends email when 
documents are modified, approved, or 
annotated. 

Collaborate with team members to build and maintain 
repository process models.  
 
Notifications keep colleagues up-to-date on the latest 
changes. 

 
To subscribe: 
In the Process Central Explorer bar, select one or more objects. On the ProcessCentral menu, choose 
Subscriptions. The Subscriptions dialog box: 
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Document Field Codes Benefit 
Display repository status information 
within an iGrafx diagram. 
 
For example, display the current 
approval status, version number, and 
most recent author in the diagram 
header. 
  

The document approval status is maintained by the 
repository and automatically updated and displayed 
within the document.  
 
Ensure that unapproved documents are always 
appropriately marked.  
 

 
To create a repository document field code: 
Check out a repository document. On the File menu, choose Page Setup, select the document name in the 
list, and click the Header tab. Click the Right Section tab, click Insert, and choose More Fields. In the New 
Field dialog box, expand Process Central, click Version, and click OK. Place the cursor before the field and 
type “Version number:” so the dialog looks like this: 

 

 
 
In the left frame, select each document component and select the Use document settings check box on the 
Header tab. Click OK. 
 
To view the field code: 
On the File menu, choose Print Preview. 
  
The repository version number displayed in the header of a diagram: 
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Approval Status Indicators  Benefit 
The repository window displays each 
document’s approval status.  
 
For example, a yellow over green icon   
indicates that the latest version is 
nominated for approval and an earlier 
version is already approved. 
 

Approval icons give a clear view of progress toward 
process model enhancements.  
 
Managers instantly see what approvals are lagging 
and need attention. 

 
To display approval indicators: 
Open C:\Program Files\iGrafx\Pro\12.0\Sample\ACME_Order.igx. In the Process Central Explorer bar, 
right-click a folder, choose Add “ACME_Order.igx”, and click OK. Select “ACME_Order.igx” in the Process 
Central Explorer bar. On the ProcessCentral menu, point to Cycles, and choose Manage. Click Approval, 
click the Start button, click OK (to set yourself as the approver), and then click Close. 
 
A yellow dot appears on the document icon displayed in the repository window: 
 

 
 
In the Process Central Explorer bar, select the document waiting for approval. From the ProcessCentral 
menu, choose Cycles, and then choose Approval Vote. Select Vote Yes, and click OK.  
 
A green dot appears on the document icon displayed in the repository explorer bar: 
 

 
 
In the Process Central Explorer bar, right-click ACME_Order.igx and choose Check Out. Make a change to 
the document. In the Process Central Explorer bar, right-click ACME_Order.igx and choose Check In.  
 
A white dot is displayed over the green dot to indicate that the latest version is not approved but there is an 
approved earlier version: 
 

 
 
In the Process Central Explorer bar, select ACME_Order.igx. On the ProcessCentral menu, point to 
Cycles, and choose Manage. Click Approval, click the Start button, click OK (to set yourself as the 
approver), and then click Close.  
 
A yellow dot is displayed over the green dot to indicate that the latest version is waiting for approval and there 
is an earlier approved version: 
 

 
 
In the Process Central Explorer bar, select ACME_Order.igx. From the ProcessCentral menu, choose 
Cycles, and then choose Approval Vote. Select Vote No, and click OK.  
 
A red dot is displayed over a green dot to indicate that the latest version was not approved and there is an 
earlier approved version: 
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Project Tracking Benefit 
Define projects and assign them to 
multiple repository objects.  
 
Assign projects a start date, end date, 
and completion percentage. 
 
Create reports and queries of project 
status across the repository. 
 

Associate processes and documents with projects to 
better understand when processes are targeted for 
improvement. 
 
Tracking indicators automatically change color if a 
project completion date might be missed.  

 
To create a repository project: 
In the Process Central Explorer bar, right-click a document and choose Properties. In the Repository Item 
Properties dialog box, click the Status tab. In the Project Name drop-down type “Sample Project”. Click the 
Start Date field, choose a date before today’s date and click OK. Click the End Date field, choose a date 
after today’s date and click OK. Enter “50” in the Percent Complete field and click OK.  
 
A color-coded project status indicator is displayed near the left border of the Process Central Explorer bar. 
 
A yellow circle indicates that the project work on the ACME_Order model will not finish by the end date at the 
current rate of progress: 
 

  
 
To create a summary project report: 
On the ProcessCentral menu, point to Repository and choose Project Report or Overdue Items. 
 
 
Multiple Select Benefit 
Highlight multiple repository objects 
before performing any of these 
commands: 
 
• View Current Version 
• Check Out 
• Label Current Version 
• Delete 
• Subscription 
• Approval vote 
• Start approval cycle 
 

Perform repository operations faster. 

 
To use multiple select: 
In the Process Central Explorer bar, click an object and then hold the Ctrl key while you click to select 
additional objects. Use either the ProcessCentral menu or right-click to choose the desired command.  
 
To use multiple select to vote or start an approval cycle, first add their command buttons to a toolbar: 
From the View menu, choose Toolbars, click Customize, in the Categories field, select Process Central, 
drag and drop the Vote or Start Approval Cycle buttons to a toolbar. 
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Repository Resource Model Benefit 
See the resource model description 
earlier in this document.  
 
Maintain the resource model in a 
repository to share and reuse resource 
objects across all repository process 
maps. 
  
From the repository window in the 
Explorer bar, add diagram swimlanes 
representing resources. 
 

iGrafx repositories provide safe storage of process 
models and documentation. Now manage 
organization and IT architecture descriptions within a 
repository and reference the resources from any 
process. 
 
Build process models faster by leveraging predefined 
resource definitions. 
 
Repository resource model changes are 
automatically pushed to all process models that use 
the repository resource model. 
 

 
To create a repository resource model: 
Open a Process Central repository. On the ProcessCentral menu, point to Repository and choose Create 
Resource Model. 
 
In the Process Central Explorer bar, right-click  and choose Check Out. Use the Add button to 
build a resource model of resources, resource types, folders and organizations. To save changes, click OK 
and then check-in the Resource Model. 
 
The repository resource model can also be created using the Process Central synchronization command in 
iGrafx Enterprise Modeler.  
 
A portion of a repository resource model: 
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View Historical Components Benefit 
View historical data on documents and 
components. 
 

Retrieve the process map most relevant to your work. 

 
To view component histories: 
In the Process Central Explorer bar, right-click an iGrafx component and choose History. Previous product 
versions only allowed the History command on document objects. 
 
 
Get Contents  Benefit 
Retrieve folders and documents from any 
repository folder.   
 

Copy large amounts of repository data for use 
outside of the repository. 
 
The repository structure and inter-document links are 
maintained in the retrieved files. 
 

 
To get folder contents: 
In the Process Central Explorer bar, right-click a folder name and choose Get Contents or Get Contents 
To.  
 
The Get Contents command retrieves documents to your local repository folder. The Get Contents To 
command retrieves documents to a specified folder. 
 
The new commands on the context menu: 
  

 
 
Web Central Enhanced Benefit 
New features include: 
 
• Initial zoom level setting 
• Link behavior control 
• Optional control over header and  

footer display  
 

Customize the web view of your iGrafx documents to 
fit the standards of your existing web content. 

 
Click Start on the Windows toolbar, point to All Programs, point to iGrafx, and choose Web Central 
Administration. In the Web Central admin page, click New and specify settings. 
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Work Products  Benefit 
This feature requires iGrafx® 
Enterprise Modeler™ to create the 
repository of work products and 
report their usage. 
 
Work products are material, forms, or 
other data such as goods, invoices, and 
purchase orders that flow through 
processes.  
 
Set work product inputs and outputs at 
each activity. 
 

Model information and data flows with reusable 
objects maintained by the repository.  

 
Use the Process Central synchronization command in iGrafx Enterprise Modeler to create Work Products in 
a Process Central repository. These work products are then associated to activities using the Enterprise page 
of the shape Properties dialog. 
 
A portion of a repository including Work Products: 
 

 
 
 
 
SQL Server 2005 Benefit 
Optionally purchase Enterprise Central 
and iGrafx Process Central bundled with 
Microsoft SQL Server 2005. 
 

Get SQL Server 2005 at the lowest possible cost. 
 
Simplify the procurement process by purchasing from 
a single source. 
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